Topics

Tams monitor


Jan Boen
 

Hi,

The Tams MasterControl communicates with JMRI via a serial port over USB using the P50x protocol. 
The Tams monitor worked 2way when developed, in the latest production version I see the polling commands as sent by JMRI but no longer the answers.
The Tams code has not been changed in years. Has anything changed JMRI side that I should be aware of? I have no clue when this stopped working, just noticed this recently when trying to debug some layout problems.

Thanks, 

Jan


Bob Jacobsen
 

Something was probably inadvertently broken. (There aren’t a lot of TAMS users to notice, so it could have been broken for a while)

To try to help narrow it down, is the underlying communications OK? I.e. can you talk to the layout, and have the layout talk back?

Bob

On Sep 5, 2020, at 1:36 AM, Jan Boen <jan.boen@...> wrote:

The Tams MasterControl communicates with JMRI via a serial port over USB using the P50x protocol.
The Tams monitor worked 2way when developed, in the latest production version I see the polling commands as sent by JMRI but no longer the answers.
The Tams code has not been changed in years. Has anything changed JMRI side that I should be aware of? I have no clue when this stopped working, just noticed this recently when trying to debug some layout problems.


Bob Jacobsen
@BobJacobsen


Jan Boen
 

Hi Bob, 

Yes all seems to work fine. 
DCC commands are sent. 
Feedback is coming in. 
Power status changes correctly. Controlling a loco directly from the Tams is correctly showing on screen. 
Only the display of p50 commands in the tams monitor is no longer working. 
Tested under Windows and Linux same result. 

Thanks, 

Jan

On 5 September 2020 17:22:11 "Bob Jacobsen" <rgj1927@...> wrote:

Something was probably inadvertently broken.  (There aren’t a lot of TAMS users to notice, so it could have been broken for a while)

To try to help narrow it down, is the underlying communications OK?  I.e. can you talk to the layout, and have the layout talk back?

Bob

On Sep 5, 2020, at 1:36 AM, Jan Boen <jan.boen@...> wrote:

The Tams MasterControl communicates with JMRI via a serial port over USB using the P50x protocol. 
The Tams monitor worked 2way when developed, in the latest production version I see the polling commands as sent by JMRI but no longer the answers.
The Tams code has not been changed in years. Has anything changed JMRI side that I should be aware of? I have no clue when this stopped working, just noticed this recently when trying to debug some layout problems.



Bob Jacobsen
rgj1927@...